Issue: 


There are a wide variety of circumstances which can affect the Page Viewer's functionality. This article addresses the following issues:
  • Page Viewer shows a blank window or does not load at all
  • Page Viewer does not reflect the same page the visitor is on
  • Page Viewer keeps showing the login page


Possible Causes and Solutions: 



Cause
The LivePerson monitor tag is incorrectly positioned or the formatting of the tag was changed

Solution
The monitor tag should be correctly positioned before the closing body tag </body> on your web site. The tag should not be enclosed within DIV or TABLE tags.
emptyStringNOTE: While placing the tag in other areas of your website may appear to work correctly, performance may not be consistent or fully functional.
The monitor tag format should not be altered. It must contain the original comments, and not have any additional line breaks (newlines) inserted.



Cause
If your site uses cookies, it is possible that you have not defined any pages within the Page Viewer settings in the Admin Console

Solution
At least one page from your website must be registered in the Admin Console at Account Set Up > Collaboration >> PageViewer.
emptyStringNOTE: If your site spans different domains (or sub domains), you will need to specify one page from each domain and sub domain.
You can also define pages to preview (before the visitor browses to it) here. This allows agents to preview pages such as the checkout basket or "discount eligibility" page without needing your visitor to browse to that page.
 

Cause
Secure (https) pages must use a Security Certificate supported by LivePerson. A full list of supported certificates can be found in the knowledgebase.

Solution
Check the list of supported certificates, if your certificate is not located there, please follow procedures on that page to submit a request for future support of your certificate.
 

 Cause
Your site is designed with dynamic content such as Flash, Silverlight or AJAX.

Solution
Pages designed using dynamic based web development techniques are not supported by PageViewer.
 

Cause
Your site uses HttpOnly cookies. The LivePerson PageViewer does not support the use of HttpOnly cookies. Pages using such cookies will not be rendered correctly

Solution
 If the page is rendered based on a session cookie and the cookie is protected with an HttpOnly header, the LivePerson script cannot access it and the page will appear as if no cookie exists. Consider using a different method to record information about your visitor's session.


Cause
Your site uses ASP.net sessions. This generally affects Internet Explorer only. This is because Internet Explorer does not allow access to cookies that mark an ASP Session. (This is true only with ASP.net not Classic ASP).

Solution
Consider using a different method to record information about your visitor's session.
 

Cause

Page Viewer requires that Internet Explorer be set up to accept cookies on the agent's computer.

Solution
Page Viewer uses Internet Explorer's default settings to render pages. Internet Explorer should be configured to accept cookies while browsing. This is particularly important when using the PageViewer to view pages which require the use of cookies.

To enable cookies please do the following:
Open Internet Explorer and select Tools > Internet Options and choose the Privacy tab.
Enter liveperson.net and then press "Allow" to add the domain to the trusted list.